[Dnscheck-dev] perl version for dispatcher

Anand Buddhdev anandb at ripe.net
Thu Jan 30 11:04:05 UTC 2014


Hi Calle,

I get this error message when trying to run the dispatcher:

# dnscheck-dispatcher
Perl v5.10.10 required--this is only v5.10.1, stopped at
/usr/bin/dnscheck-dispatcher line 33.
BEGIN failed--compilation aborted at /usr/bin/dnscheck-dispatcher line 33.

Does the dispatcher really need at least 5.10.10? What's the reason for
it? The standard version of perl on CentOS 6 is 5.10.1, and I can't
upgrade it easily.

By the way, if this really is a requirement, should it not be checked
when running "perl Makefile.PL"? This requirement has caught me by surprise.

Regards,
Anand


More information about the Dnscheck-dev mailing list