[Dnscheck-dev] Filter not working

Anand Buddhdev anandb at ripe.net
Fri Jan 24 23:52:52 UTC 2014


Hi DNSCheck devs,

I have defined the following in /etc/dnscheck/config.yml:

filters:
  'NAMESERVER:NOT_AUTH':
    - args: [ ns.ripe.net, 193.0.9.6 ]
      level: WARNING

However, when I run dnscheck, I still get an error where I expected a
warning (I've filtered out the INFO-level messages):

$ dnscheck 14.109.in-addr.arpa|grep -v INFO
  2.299: 14.109.in-addr.arpa NOTICE Too few IPv6 name servers (1).
  2.560: 14.109.in-addr.arpa NOTICE DNS lookup error (SERVFAIL).
  2.602: 14.109.in-addr.arpa NOTICE DNS lookup error (SERVFAIL).
  2.643: 14.109.in-addr.arpa NOTICE DNS lookup error (SERVFAIL).
  2.690: 14.109.in-addr.arpa NOTICE DNS lookup error (SERVFAIL).
  3.460: 14.109.in-addr.arpa WARNING Nameserver at 193.0.9.6 is not
authoritative over UDP.
  3.460: 14.109.in-addr.arpa ERROR Name server ns.ripe.net (193.0.9.6)
not authoritative for 14.109.in-addr.arpa.
  6.708: 14.109.in-addr.arpa WARNING The listed nameservers for
14.109.in-addr.arpa does not all report the same set of nameservers.
  8.101: 14.109.in-addr.arpa NOTICE SOA MNAME for 14.109.in-addr.arpa
(nsrevprov.dns.sfr.net) not listed as NS.
 21.052: 14.109.in-addr.arpa NOTICE SOA refresh for 14.109.in-addr.arpa
too small (10800) - recommended >= 14400.
 21.427: 14.109.in-addr.arpa NOTICE Zone announced by fewer than two
IPv6 ASN.


Have I misunderstood the filter syntax?

Regards,
Anand


More information about the Dnscheck-dev mailing list